Resolved
All good.
Monitoring
All active clusters have recovered.
Identified
A routine update caused an issue with one of our storage nodes. We are currently working on a remediation
Investigating
We are currently investigating a small number of clusters facing I/O errors in us-east-1 region