History

Resolved
February 23 6:36 PM UTC

The issue has been resolved. Branch Management features in the UI are fully functional again.

Monitoring
February 23 6:29 PM UTC

We have deployed the code fix and monitoring recovery in all regions.

Identified
February 23 5:10 PM UTC

We have identified the root cause in a recent code change and we are currently working on a fix.

Investigating
February 23 4:54 PM UTC

We are investigating Web UI errors from Branch Management functionalities such as "Add a branch" and "Manage branches".