History

Resolved

The issue has been resolved. Latency is back to the expected level in all regions.

January 24 5:03 PM UTC
Monitoring

A fix has been deployed. We are monitoring closely as latency in all regions is returning to expected levels.

January 24 4:47 PM UTC
Identified

We have identified the root cause for the increased latency in a recent code update and we are working on a fix.

January 24 3:16 PM UTC
Investigating

We are observing increased query latency in all regions. We are currently investigating.

January 24 2:53 PM UTC